What is the error "identity of the developer cannot be confirmed"?

When installing ConnectEasy on Macs, you may run across the error message:

"ConnectEasy" can't be opened because the identity of the developer cannot be confirmed.

This error may occur during the initial launching of ConnectEasy, due to recent security changes in Mac OS X 10.10 and 10.11. Fortunately, the error is benign and it is easy to workaround.

To allow ConnectEasy to run on your Mac computer.

  1. Click OK if you encounter the error message above.
  2. Click on Security & Privacy in System Preferences:
    mac_OS_security_and_privacy.PNG
  3. Click to Allow app downloads from App Store and identified developers
    mac_OS_select_developer_option.PNG
  4. Next, press and hold the Control key, then single click on the ConnectEasy application icon.
  5. Choose Open from the shortcut menu.
  6. Click Open.

 

Was this article helpful?
14 out of 26 found this helpful

Comments

Add a Comment

Please sign in to leave a comment.